CVE- 2015 - 2755

Posted On // Leave a Comment

Overview 

Multiple cross-site request forgery (CSRF) vulnerabilities in the AB Google Map Travel (AB-MAP) plugin before 4.0 for WordPress allow remote attackers to hijack the authentication of administrators for requests that conduct cross-site scripting (XSS) attacks via the (1) lat (Latitude), (2) long (Longitude), (3) map_width, (4) map_height, or (5) zoom (Map Zoom) parameter in the ab_map_options page to wp-admin/admin.php.

Impact

CVSS Severity (version 2.0):
CVSS v2 Base Score: 6.8 (MEDIUM) (AV:N/AC:M/Au:N/C:P/I:P/A:P) (legend)
Impact Subscore: 6.4
Exploitability Subscore: 8.6
CVSS Version 2 Metrics:
Access Vector: Network exploitable; Victim must voluntarily interact with attack mechanism
Access Complexity: Medium
Authentication: Not required to exploit
Impact Type: Allows unauthorized disclosure of information; Allows unauthorized modification; Allows disruption of service

 CSRF/Stored XSS Vulnerability in AB Google Map Travel (AB-MAP) Wordpress Plugin

Overview

  • Title :Stored XSS Vulnerability in AB Google Map Travel (AB-MAP) Wordpress Plugin
  • Author: Kaustubh G. Padwad
  • Plugin Homepage: https://wordpress.org/plugins/ab-google-map-travel/
  • Severity: HIGH
  • Version Affected: Version 3.4 and mostly prior to it
  • Version Tested : Version 3.4
  • version patched: 4.0
  • CVE ID : CVE-2015-2755

Description

Vulnerable Parameter

  • Latitude:
  • Longitude:
  • Map Width:
  • Map Height:
  • Map Zoom:
  • And all Input Boxes

About Vulnerability

This plugin is vulnerable to a combination of CSRF/XSS attack meaning that if an admin user can be tricked to visit a crafted URL created by attacker (via spear phishing/social engineering), the attacker can insert arbitrary script into admin page. Once exploited, admin?s browser can be made to do almost anything the admin user could typically do by hijacking admin's cookies etc.

Steps to Reproduce: (POC)

After installing the plugin After installing the plugin
  1. Goto settings -> Google Map Travel
     2. Insert this payload ## ">
+-+-1-+-+alert(/1/) ## Into Any above mention Vulnerable parameter Save settings and see XSS in action
  1. Visit Google Map Travel settings page of this plugin anytime later and you can see the script executing as it is stored.



CSRF POC

Plugin does not uses any nonces and hence, the same settings can be changed using CSRF attack and the PoC code for the same is below

Kindly refer this for CSRF POC 

Mitigation

Update to version 4.0

Disclosure

07-March-2015 Reported to Developer 11-March-2015 Reported to Wordpress 11-March-2015 Acknowledgement from Developer 16-March-2015 Wordpress reviwed and publish the updated plugin. 16-March-2015 Requested for CVE ID 27-March-2015 CVE Assign 28-March-2015 Reposted with CVE ID

credits